Шашечная программа Эдэон-100 – Эксперт дебютов и эндшпиля в международных шашках.

Эдэон-100 – программа-лаборатория для творческих людей и для игры в международные шашки с богатыми возможностями:
1. Игра с чемпионами мира
2. Игра с разными движками и программами по протоколу Dxp
3. Самообучение программы Эдэон-100
4. Возможность выполнения шашечных разрядов прямо в программе Эдэон-100
5. Удобная работа с 250 000 базой партий
6. Работа с супербазой книг (4 книги бесплатно)
7. Текстовые комментарии к ходам, вариантам и дебютам
8. Метки к теоретическим ходам (буква Т) и личные метки к своим секретным вариантам
9. Дополнительный модуль «Миниатюры», всё для композиции + 2 тренажера по комбинациям и эндшпилю

1. Процедура установки программы «Эдэон-профи»
Скачайте установочный диск программы Эдэон по ссылке, которую Вам вышлет команда Эдэон.
Разархивируйте скачанный файл на любой диск Вашего винчестера: С или D:
Запустите установочный файл setup.exe и выберите на какой диск установить программу.
1. Запустите программу Эдэон.

2. В появившемся окошке программы введите свою фамилию и имя (1) , поставьте галочку «Привязать к флешку-диску»(2)
выберите флешку (3), нажмите «Сохранить» (4) и вышлите файл EDEON.key по адресу: vasily.naumik@gmail.com
3. Скопируйте присланный Вам файл edeon.key в папку Z-Z, вставьте флешку(без флешки Эдэон работать не будет).
4. Запустите программу от имени администратора (правой кнопкой мышки нажать по иконке Эдэона на рабочем столе).

2. Работа с программой Эдэон-100

2.1 Запуск программы Эдэон-100 и Главное окно программы.

Запустив программу Эдэон-100, вы попадаете в одну из оболочек «Главного окна» программы «Эдэон-100», которая выглядит следующим образом:

2.2 Настройка программы Эдэон-100
Для начала уберём синий фон, нажав на зеленый прямоугольничек под меню «Оболочки»(Цифра 1)

Затем для игры создадим игрока. Для этого Затем наведите курсор мыши под правый нижний угол шашечной доски над маленьким черным треугольником и нажмите на всплывающую кнопку.(Цифра 2) Появится меню «Создать игрока»
Нажмите меню «Создать»(Цифра 3)

Напечатайте свое имя и фамилию(Цифра 4) и нажмите «Готово»(Цифра 5)

Затем щелкните по фамилии игрока(Цифра 6) и поднимите игрока под Вашей фамилией на самый верх, нажав кнопку «Стрелка вверх»(Цифра 7) и чтобы всё сохранить: нажмите на зелёную галочку(Цифра 8 ).
Затем откроем второе важное окно Эдэона «Протокол партий». Для этого нажмите невидимую кнопку(Цифра 9) и поставьте галочку «Показывать протокол партии»(Цифра 10) или можно было просто нажать на квадратик с полосками(Цифра 11) и выбрать «Показывать протокол партий»

Уменьшаем и располагаем протокол партий справа(можно и под программой) и в итоге мы получаем такой вид программы Эдэон:

Продолжим настраивать Эдэон. Нажмем меню «Настройки»(Цифра 12) и «Ходы позиции»(Цифра 13) и поставим галочки как на картинке.(Цифры 14-15)

Затем нажмем меню «Комментарии»(Цифра 16) и расставим галочки, как на картинке внизу.(Цифра 17) И нажимаем кнопку «Готово»(Цифра 18 )

Всё! Эдэон настроен! Смотрите первый рисунок в начале этой «Помощи»

2.3 Всплывающие кнопки
Познакомьтесь с всплывающими кнопками настроек 1 – 10, при наведении на них курсора мыши:

Структура Эдэона - это 10 модулей, 9 меню , 2 объекта шашек игрока (белой и черной) и панели графика оценки силы ходов.(в нижнем правом углу Эдэона)
Модули – можно настроить при нажатии всплывающей кнопки: при наведении курсора мыши на верхний правый угол модуля.

Перечислим 10 модулей Эдэона:
1. Часы белых 2. Часы черных 3. Тип игрока за черных и белых. 4. Текущие настройки Эдэона за черных или выбор игрока или уровня в зависимости что стоит в поле «Тип игрока» 5. Доска 6. Комментарии 7. Статистика. 8. Партия.
9. Ходы позиции 10. Игроки.

Перечислим 9 меню Эдэона:
1. Новая игра 2. Дебюты 3. Расстановка позиции.4. Базы партий 5. Анализ 6. Настройки.7 . Оболочки 8. Фон оболочек
9. Справка. 10. Выход из программы Эдэон

Для начала дадим понятие «Объект шашки игрока».

Объект шашки игрока – является многофункциональным объектом. Он обозначает цвет шашек, которыми играет игрок и отмечается рамкой, если в данный момент ход у этого игрока, в данном случае у черных.

Если перетянуть шашку игрока на игровое поле, то произойдет переход в режим быстрой расстановки позиции. Если шашка была отпущена над черным полем, то она установится на это поле.

О нахождении в режиме быстрой расстановки позиции сообщает точка в левом верхнем углу доски. Клик по этой точке в цикле очищает доску от шашек или расставляет начальную позицию. Выход из режима быстрой расстановки позиции осуществляется нажатием на любом белом поле доски или нажатием на кнопку «Расстановка позиции».

Нажатие левой или правой клавишей мыши расставляет шашки на соответствующем чёрном поле. Также для расстановки можно использовать шашку игрока, перетаскивая её на доску. При этом клик правой кнопкой мыши меняет вид шашки игрока с простой на дамку и обратно.

Клик левой кнопкой мыши на шашку игрока меняет тип игрока между человеком и последним использованным движком. Эту возможность можно использовать для остановки обдумывания хода движком.

При быстром двойном нажатии на шашку игрока во время обдумывания хода движком будет сделан предпочитаемый этим движком на данный момент ход.

3. 10 модулей Эдэона.

Рассмотрим 10 модулей Эдэона по порядку:

3.1 1.Часы белых 2. Часы черных:
Часы показывают время игры и позволяют выбрать тип учёта времени. Если выбрано время на ход, то часы идут в возрастающем порядке, если же выбрано время на партию, то часы идут в убывающем порядке.
Клик по времени игрока обнуляет его. Клик по стрелкам (если они показаны) или по типу времени увеличивает-уменьшает время игры или меняет тип учёта времени.

Поставить время можно и через кнопку настроек 2

3.2 Тип игрока за черных и белых:

В этом поле выбирается тип игрока.
Человек – игра осуществляется человеком. Его имя выбирается в поле игрока.
Эдэон – обдумывание и ходы осуществляет движок программы Эдэон. В поле игрока можно выбрать настройки программы обдумывания и они загрузятся в программу.
Движок – ходы делает движок сторонних разработчиков, использующий для взаимодействия с оболочкой протокол Dxp.
Но для этого надо сначала подключить сторонний движок к оболочке Эдэон-100. Рассмотрим как это делать.

Выбираем «Движок» и нажимаем невидимую кнопку (3), в появившемся окошке нажимаем «Добавить движок»(4), печатаем имя движка(5), указываем путь к программе через кнопку(6),ставим параметры Командной строки -p 27531 (7),IP-адрес 127.0.0.1 (8),TCP-IP-порт 27531 (9), ставим галочки Белыми и черными (10) и нажимаем «Готово» (11)
Таким же образом настраиваем и движок Scan 2.0 , только в параметрах Командной строки ставим Dxp, как на рисунке ниже, цифра (7)

Теперь можно выбрать движки, чтобы они играли между собой матчи.
К примеру, за белый цвет выбираем Эдэон, затем ставим время на игру, за черный цвет выбираем – MobyDam или Scan 2.0 и после загрузки стороннего движка появляется окно:

где можно выставить количество партий и наслаждаемся игрой движков между собой в автоматическом режиме. Можно также, чтобы матчи игрались по различным дебютам, для этого предварительно нажмите кнопку «Дебюты» и выберите, что Вам надо для матча.

Рассмотрим, как организовать матч между Эдэоном-100 и программой Kingsrow. Для этого в Эдэоне надо выбрать движок (Цифра 1) DamExchangeprotocol(DXP) (Цифра 2), затем выбрать «Подключиться к другой программе»(Цифра 3), а у программы Kingsrow в меню «Game» надо выбрать «Wait For Dxp conection» (Цифра 4)

Внимание! В кодах движков могут быть ошибки и недочёты, не контролируемые программой Эдэон. Поэтому программа, в случае, если движок не отвечает на её запросы, останавливает работу движка и пытается его перезапустить. В этот момент может происходить затормаживание работы программы или появление окна ошибки Edeon-Engines, которое можно закрыть. На работу программы это не влияет.

База партий – при выборе этого типа игры ходы будут выбираться из базы партий на основании созданного фильтра. Если в отфильтрованных партиях нет текущей позиции, то ход сделает последний использованный движок.
Игра по базе партий – позволяет играть против любого игрока, партии которого есть в базе партий, в том числе и против чемпионов мира. Выберите в «Типе игрока»(цифра 1) «База партий»(цифра 2) и выберите игрока через черный треугольничек(цифра 3), к примеру легендарного гроссмейстера Сейбрандса Т.

Для того, чтобы добавить нового человека в «Фильтр базы партий – нажмите меню «База партий» (цифра 1) и нажмите кнопку «Фильтр»(цифра 2)

и в появившемся меню нажмите кнопку «Добавить»(цифра 3) – и появится «новый фильтр».
В поле «Имя фильтра»(цифра 4) впишите вместо слова «Новый фильтр» – любую фамилию с буквой Б, например Б Сейбрандс Т, чтобы он играл белыми и перейдите к полю «Белыми»(цифра 5), и напечатайте вручную Sijbrands, нажмите обязательно на черный треугольник(цифра 6) и щелкните мышкой по фамилии Сейбрандс. и затем нажмите «Загрузить»(цифра 7 ) и программа Эдэон будет делать все ходы Сейбрандса за белый цвет из базы партий. Можно, конечно убрать галочку со счета «0-1», чтобы не делались ходы Сейбрандса из проигрышных партий базы партий. Аналогично делаем фильтр за черный цвет с буквой «Ч»(черные)

Партнёр позволяет играть партии с соперниками разного уровня. При этом, если не было возврата позиции, анализа и подобного, то при выигрыше текущему игроку начисляются баллы. Начинающий партнер делает ходы случайным образом.
Разряд – игра этого типа аналогична игре с Партнером, но при выигрыше Эдэон присвоит игроку соответствующий разряд. Для получения разряда следует из четырёх подряд идущих партий выиграть у соперника две, без возврата ходов и перехаживания ходов.

4. Доска.
Оформление доски и способ хождения можно настроить, нажав кнопку контекстных настроек(Цифра 1) в правом верхнем углу доски.

Затем можно выбрать вид доски(Цифра 2),время на шаг шашкой(Цифра 3),отключить или включить звук передвижения шашки(Цифра 4) и запомнить настройки(Цифра 5)

Как ходить шашкой?
Можно ходить, перетаскивая шашки, захватив мышкой, или указывая щелчком мыши шашку и клетки, по которым она должна делать ход. Если включен автобой, то программа будет автоматически делать ход с битьём.
Если включен режим «автоход», то программа будет автоматически делать ход, если он единственно возможный для текущей ситуации. Это относится и к случаю, когда указано несколько полей текущего хода. Если по отмеченным клеткам проходит один ход, то программа автоматически завершит ход.
Если нет автохода, то всегда нужно конкретно указывать все клетки хода. В случае со множеством сложных ходов желательно указывать клетки хода по порядку.

5. Комментарии

Здесь мы видим, что есть в этом модуле. Если галочка стоит в маленьком квадратике – тогда эта возможность в Эдэоне будет работать.

Нажав кнопку настроек в правом верхнем углу модуля «Комментарии», мы увидим следующие возможности:

1. «Показывать». Комментарии будут показываться при стоящей галочке.
2. «Можно редактировать». Позволяет комментировать ходы при стоящей галочке.
3. «Сохранять автоматически»
4. «Статистика базы партий». Будет показываться статистика при стоящей галочке.
5. «Число позиций с комментариями». Позиции с комментариями можно просматривать стрелками вправо и влево.
6. «Название файла комментариев»
7. «Сохранить исправления»
8. «Сохранить все комментарии в pdn-файле»
9. «Загрузить комментарии из pdn-файла»

6. Статистика

Можно какие-то показатели статистики(цифра 7) включить или выключить. Не забывайте нажать зеленую птичку.

Над панелью информации из дебютной и эндшпильной базы находится надпись «Темповая разность» – это разница между темповым числом белых и чёрных.

7. Партия При нажатии невидимой кнопки(Цифра 1) появляется такое окно:

Тут можно производить любые операции с текстом партии + включать значки к ходам в дебютной базе и « Показывать протокол партии». Значок «Т» – обозначает «теоретический ход»
Панель «Нотация» выводит текст ходов партии.

При переходе мышкой по ходам партии текущий ход выделяется полоской. Также Вы можете щелкнуть на любом ходе в тексте партии, чтобы переместиться к соответствующей позиции.

В панели нотации также есть два «градусника(2 вертикальные полоски)»:
один для ходов белых, а другой градусник для ходов черных. Поставьте допустим движок Эдэон за черных и движок Scan за белых, и сыграйте партию.
И Вы увидите две вертикальные полосы для ходов белых и для ходов черных.
Плохие ходы будут обозначены красной полоской(цифра 2). Хорошие ходы – голубой полоской(цифра 1).
Чем ярче цвета – синий, допустим, тем ход сильнее. А чем краснее, тем слабее ход.

8. Ходы позиции

Мы видим окно «Ходы позиции», если нажать невидимую кнопку(Цифра 1) и если стоят флажки напротив «Оценки дебютной библиотеки» и напротив «Можно редактировать, то редактирование ходов в дебютной базе возможно. Полезно поставить и все остальные галочки, если хватает оперативной памяти для нормальной работы Эдэона.

9. Игроки

При нажатии невидимой кнопки(Цифра 1) – появляется окно, где можно создать игрока, изменить изображение, стрелками передвинуть игрока выше или ниже или удалить игрока

4.Меню Эдэона

Рассмотрим 9 меню Эдэона, которые находятся слева от доски:

4.1 Новая игра
При нажатии расставляется начальная позиция или позиция из жеребьевки.

4.2 Дебюты

Меню «Дебюты»позволяют выбрать начальную позицию игры. При этом, если в окне дебютов отмечены начальные позиции (кнопка меню «Дебюты» в этом случае подсвечивается), то при нажатии на кнопку «Новая партия», на доске будет расставлена позиция из базы дебютов. Далее поставьте галочку «Играть отмеченное»(цифра 1)
Появится следующее окошко программы, где можно поставить галочку, к примеру «Случайным образом»(цифра 4) и поставить галочку All(все) debuts(дебюты)(цифра 2) и при желании «Одну и ту же позицию играть попеременно Микроматч»
И в завершении нажать «Готово»(цифра 3)
А вообще можно просто щёлкнуть по любой позиции дважды мышкой и она загрузится для игры или для работы.

4.3 Расстановка позиции

Позицию на доске можно расставить любым удобным способом – перетаскиванием любой видимой шашки на клетку либо кликом левой или правой кнопкой мышки по полю доски. Кроме того, нажав на значок дискеты можно сохранить текущую позицию, дать ей название, написать комментарий, сохранить в графический файл.

4.4 Базы партий
Работа с базой партий осуществляется в отдельном окне. При первом открытии окна база партий будет отфильтрована по текущей позиции. При следующих открытиях в окне будут отображаться партии, который находились в нём при закрытии.
При нажатии кнопки «База партий»(цифра 1) , компьютер ищет расставленную позицию на доске в базе партий и выдаёт в другом окне все партии, где эта позиция встречалась с именами игроков, названия турнира, результата и года.

Выдаётся также статистика по этой позиции: сколько выигрышей, ничьих и проигрышей. Если нажать кнопку Текущая позиция в начальной расстановке шашек, Вы увидите количество партий в базе. А если нажмёте кнопку Фильтровать, и Статистика то увидите общее количество партий вместе с жеребьёвкой дебютов. Их около 400 000 партий.

Если нажать на это количество партий(около 250 000) – тогда выдастся статистика по игрокам.

Можно фильтровать и текущую позицию, нажав кнопку Текущая позиция, когда работаете с нотацией, причём из любого места нотации.

Партии из списка можно редактировать, нажав правую кнопку мыши и нажав поле изменить или удалять по одной или группами.

Партии из списка можно проиграть в автоматическом режиме нажав кнопку треугольничек.

Можно проанализировать любую партию, нажав кнопку А, рядом с черным треугольничком

[White "Тарасян К.А."]
[Black "Федоровых Н.Б."]
[Event "Международный турнир "Белые ночи - 2016" (RusWN-20"]
[Date "2016.09.02"]
[Result "1-0"]
[GameType "20"]

Выбираем нужные требования и нажимаем кнопку анализировать.
Будут выведены комментарии и оценки ходов, как ниже:
1. 32-28{(-3) [!] Дебют Рафаэля.
Ход в центр сильно исследован.
У белых есть 9 систем. } 18-22{(-8) [!] Голландская система.
старинная система игры за черных была очень популярна в 40-е годы. Не утратила она своей притягательной силы и в наши дни.
Стабильная популярность голландской системы объясняется очень просто: черные с первого же хода уходят от набивших оскомину классических построений (позиций типа Вольдуби) и создают предпосылки для перехода к коловым схемам.
У белых три варианта 37-32, 38-32 и 34-29} 2. 37-32{(4) [!]}

Партии можно просмотреть в ручном режиме стрелками или в автоматическом режиме, нажав маленький чёрный треугольник справа от стрелок. Можно перевернуть доску – F5

Можно смотреть в автоматическом режиме целые группы партий. Для этого надо выделить нужные партии, нажав Ctrl и щёлкать мышкой по нужным партиям.

Если щёлкнуть правой кнопкой мышки по нотации партии, то её можно не только играть в автоматическом режиме, но и сохранить в текстовом файле. Регулируется также и скорость показа партий – для этого надо в автоматическом режиме показа партии, нажать > для увеличения скорости или < для уменьшения скорости. Можно растянуть доску, потянув ее мышкой вниз или вбок
Режим фильтрация предназначен для поиска(фильтрации) любого игрока(белыми или чёрными) или любого турнира.
Для этого надо щёлкнуть мышкой по полю любой игрок или любой турнир и нажать любую букву и дальше работать колесом мышки или кнопками Page Up или Page Dn. или напечатать полностью фамилию и все равно затем мышкой выбрать эту фамилию из базы, иначе фильтрация не сработает.

Если Фамилия за белых и за чёрных совпадает – будут выведены все партии и за белый и за чёрный цвет. Если щёлкнуть мышкой по кнопке счёт – произойдёт фильтрация по результатам.
Также можно фильтровать по дате, по фамилии, по турнирам, белыми, чёрными. Можно перетаскивать мышкой к примеру счёт налево в самый край и опять щелкать по счёту – будет фильтрация по годам.

4.5 Анализ
Нажмите кнопку Анализ(цифра 1). У Вас начнутся анализироваться ходы в окне дебютной базы.

Могут анализироваться все ходы или один ход. Это зависит от настроек программы.Если не стоит галочка «Начинать анализ с выделения всех ходов»(цифра 3) – тогда будет анализироваться один ход. Если галочка будет стоять(цифра 3) – тогда анализироваться будут сразу все ходы. Быстро переключаться между анализами всех ходов и анализом одного хода можно клавишей F9

Посмотреть, стоит ли галочка в настройках, можно при помощи невидимой кнопки(цифра 2)
Можно щелкнуть мышкой по любому ходу, а можно и по нескольким ходам и выбранный движок будет анализировать выбранные ходы.

Мы видим, как движок Эдэон одновременно анализирует ход 1. 32-28 и ход 1. 32-29, располагая цепочки ходов в строчку и показывая Основной вариант.

Можно изменить расположение цепочки, нажав стрелку вниз(цифра 4) перед цепочкой ходов.

Можно выделить поочередно и все ходы для анализа.

Можно по цепочкам ходов во время анализа щелкнуть и выделить их и скопировать их в буфер обмена, а оттуда в любой текстовый редактор или документ или html документ.

Анализировать можно текущую позицию или ходы текущей позиции. Программа начинает анализ с позиции. Чтобы анализировать ходы, нужно в окне текущих ходов кликнуть интересующие ходы.
Эдэон будет анализировать, пока Вы не сделаете ход или не нажмете кнопку назад.

4.6 Настройки

При нажатии кнопки «Настройки»(цифра 1) – появляется окно настроек программы Эдэон-100
Настройки дают возможность изменять одновременно все параметры программы Эдэон-100.
Выберем к примеру самый верхний параметр «Эдэон»(цифра 2),затем параметр «Эндшпиль»(цифра 3) и поставим вручную объем буфера памяти(цифра 4) равным 1000. Это эе действие можно сделать с помощью ползунка.(цифра 5)
По умолчанию программа Эдэон сама определяет, сколько ей надо памяти.(цифра 6) Обычно это 70 процентов от всего объема оперативной памяти. Поэтому если памяти 4 гб или меньше, то лучше ставить 1000 мб или 500 мб
Чтобы начать играть или анализировать Эдэон-100 также важно чтобы буфер был заполнен на 100 процентов(цифра 7)
Чтобы он заполнялся в фоновом режиме надо поставить галочку.(цифра8) А если надо, чтобы было видно как идет загрузка эндшпильных баз в буфер памяти – тогда снимите эту галочку.(цифра8)
Чтобы Эдэон-100 запомнил все изменения в настройках нажмите «Готово»(цифра 9)

Также изменение параметров работы программы можно осуществлять по ходу дела сразу в программе Эдэон-100 с помощью контекстных настроек, которые появляются при нажатии кнопки со стрелкой, высвечивающейся в правом верхнем углу соответствующего объекта, при попадании указателя мыши на этот объект, как это было описано ранее.

4.7 Оболочки

Оболочки определяют внешнее оформление программы. Три кнопки задают предпочитаемые оболочки, которые задаются с помощью окна настроек, вызываемого нажатием на кнопку с многоточием.
Также смену оболочек можно производить нажатием на цифровые кнопки клавиатуры – 1, 2 или 3.

4.8 Фон оболочек

При нажатии на цветные прямоугольники можно менять цвет фона оболочек

4.9 Справка
При нажатии на черный треугольничек появляется меню, где можно вызвать справку,
обновить программу, посмотреть «регистрационные данные» и посмотреть «о программе»

4.10 Выход из программы Эдэон

Нажатие на эту кнопку закрывает программу, плавно гася окно.

Рассмотрим некоторые режимы программы Эдэон :

5.Передвижение шашек

Передвижение шашек на доске в программе Эдэон 4 – практически универсальное.

Единственные ходы программа делает автоматически (можно одним нажатием кнопки отключить этот режим).
Шашка передвигается после нажатия начального поля и конечного. Для совершения хода достаточно нажать только начальное поле, если с этого поля единственный ход.

Кроме того, можно нажать на клавишу мыши и, не отпуская ее передвигать до нужного поля.

Можно поднять шашку и поставить ее на любое близлежащее поле(дамку на любое поле)

6. Протокол партий
Также с панелью «Нотация» тесно связан «Протокол партий», который можно открыть через клавишу F11 или кнопку (цифра 1) Нажмите «Показать протокол партии»(цифра 2) и загрузится «Протокол партий». Кнопка «Черный треугольничек»(цифра 3) показывает, что загружено и что закреплено в окне «Протокол партий» и также названия последних 10 использовавшихся файлов.

Размер окна протокола партии изменяется при помощи линий окна или надо схватить левой кнопкой мыши правый нижний угол окна и потянуть влево-вверх по диагонали. Окно уменьшится. Такую же операцию по уменьшению окна можно произвести и с Эдэоном.

Подключение бесплатной Малой супербазы 5 книг, которую можно скачать здесь.

и архив 5 книг малой супербазы 100 по отдельности здесь: архив 5 книг малой супербазы 100

Малая супербазакниг100 состоит из следующих книг:
1. Гантварг А. «50 поединков на 100 клетках» с примечаниями голландцев.
2. Вирсма Х. «1000 миниатюр»
3. Городецкий В. «Книга о шашках.Международные шашки»
4. Рокитницкий А. «В помощь любителю. Международные шашки»
5. Бакумец «Композиция 100″

Скачать малую супербазу книг в формате pdf можно здесь: малая супербаза книг в формате pdf

В Полной супербазакниг 100 содержатся 54 книги.

Список 54 книг скачать можно здесь: список 54 книг супербазыкниг 100

Планируется добавление 100 книг по международным шашкам.

Для подключения бесплатной малой супербазы 5 книг:

1) Нажмите в протоколе партий «Файл»(цифра 1)
2) Затем выберите Протокол партий в Эдэон-формате(edn)(цифра 2)
3) Щелкните 2 раза по файлу малой супербазы 5 книг

Закрепляем базу книг в протоколе партий. Для этого нажимаем значок под цифрой 1, ставим галочку «Фильтровать по текущей позиции» (цифра 2) и нажимаем для сохранения настроек зеленую галочку (цифра 3)


Далее нажимаем меню «Настройки»(цифра 1) и выбираем «Область параметров» (цифра 2). Ставим галочку «Встречаемость текущей позиции…» (цифра 3)
и нажимаем для сохранения настроек зеленую галочку (цифра 4)

И появляется такой вид настроенного Вами «Протокола партий»

Рассмотрим для чего служат четыре объекта, пронумерованными цифрами от 1 до 4.
1. Число постоянно показывает информацию из супербазы книг. Чтобы увидеть эту информацию, надо нажать на эту цифру левой кнопкой мышки
2. Чтобы играть новую партию с подключенной супербазой книг
3. Служит для возврата в протокол играемой партии
4. Служит для просмотра содержимого книг

Рассмотрим некоторые меню протокола партий:
Кнопка «Вставить диаграмму» вставляет изображение доски с соответствующей позицией в протокол партии в любое место.
Если нажмете «Сохранить» то откроется панель для сохранения файла
Те же самые операции «Открыть» и «Сохранить» характерны для «Базы партий»
Если был загружен файл, а затем нажата кнопка «Сохранить» под кнопкой «База партий», то программа добавит файлы пакета к базе партий.
Кнопка «Сохранить как…» позволяет сохранять партии в формате rtf (doc), который понимают большинство текстовых редакторов, pdn и формате Эдэона «edn»
Протокол партии тесно связан с панелью «Нотации». В ней всегда загружена партия с участием выбранного в редакторе хода. Например, если выбран второстепенный ход, то в нотации появится партия с этим ходом.
Чтобы удалить ходы справа от текущего, следует нажать клавишу Ctrl и, не отпуская её, Delete (Del), т. е. Ctrl+Delete. В этом случае будут удалены все ходы, следующие за текущим (все они представлены в панели «Нотация»).
Следует отметить, что если при нажатии указанной комбинации каретка располагается внутри комментария, то будет удалено слово или ряд символов справа. Поэтому, для удаления хода следует расположить каретку в конце комментария.
Текущий ход можно удалить с помощью меню или с помощью комбинации клавиш Ctrl+←(Backspace). Удаление аналогично выше описанному методу, только дополнительно удаляется текущий ход.
Ввод комментариев производиться за текущим ходом простым набором текста.

Также есть очень ценная функция «лоцман». Соль ее в следующем: при наведении курсора на любой ход, автоматически выделяются одним цветом все ходы, имеющие отношение к ходу с курсором.
То есть сразу видно, где в тексте заканчивается данный вариант или подвариант и т. д.

7. История партий

После нажатия кнопки «История партий» покажется окно с историей партий, которые были сыгранны или рассмотрены в протоколе партий.

Любую из партий или выбранные партии по фильтру можно загрузить в Эдэон и протокол партий для анализа.

8. Настройки протокола партий

После нажатия кнопки «Настройки» показывается окно настроек «Протокол партии»:
в котором можно настроить работу редактора, «области параметров» и «анализа» требуемым образом.
Изменив настройки можно нажать кнопку «Применить», чтобы увидеть результат. Кнопка «Исходные настройки» возвращает все настройки в первоначальное состояние.

9. Панель нотации
Под панелью нотации :

Вы видите 6 соответствующих кнопок: в начало партии (цифра 1), ход назад(цифра 2), ход вперед(цифра 3), в конец партии(цифра 4), кнопку черный треугольник(цифра 5) – автоматически играть партию с регулируемой скоростью. Для изменения скорости надо щелкать несколько раз по кнопкам: ход назад, ход вперед, когда нажата кнопка автоигры сыгранной партии. И кнопку квадратик с полосками(цифра 6).При нажатии этой кнопки – выпадает окно с двумя меню: «Предложить ничью»(цифра 7) и «Показать(скрыть) протокол партии»(цифра 8).История партий (цифра 9)

Если какой-то движок долго думает над ходом, можно заставить его сделать принудительно ход. Нажав на черный квадратик, который появляется на месте черного маленького треугольника.

10. Окно дебютной и эндшпильной базы.

Рассмотрим окно дебютной и эндшпильной базы.

В панели содержится все возможные ходы в позиции и информация из дебютной и эндшпильной базы и ходы из базы партий, которые помечены другим цветом.

Ходы людей из дебютной базы помечены [ . ]
выигрышные ходы помечены [х],
хорошие ходы из дебютной базы помечены [ ! ], [ +],
проигрышные ходы из дебютной базы помечены [ ? ],
нежелательные ходы [ - ].
Теоретические ходы помечены буквой Т
Секретные ходы только для себя помечены черным кружочком

Ходы из базы партий отображены в процентах,
выигрыши обозначены через + , ничьи через = , проигрыши через «-»
Режим редактирования ходов работает только в том случае, если дебютная база загружена в оперативную память и включен знак «Можно редактировать».
Зелёным цветом выделяются ходы игрока, который задан в настройках-ходы позиций-Статистика по фильтру – Раздельно

11. Работа над ходами партии

Рассмотрим, как работать над ходами в окне «Партия»
Для работы над ходами в этом окне, надо щёлкнуть правой кнопкой мыши по ходу – тогда откроется следующая панель:

По этим значкам надо щёлкать уже левой кнопкой мыши.

В самом низу находится меню Импорт оценок , при нажатии на него откроется окно «Импорт оценок в дебютную библиотеку»

Вверху надо выбрать файл с сыгранными партиями программ.

Предусмотрено два режима работы импорта оценок: без числовых оценок в файле и с
числовыми оценками в файле. Числовые оценки в файл «пдн» дает только Эдэон при поставленной галочке «Статистика»

Если числовых оценок ходов в этом файле нет, надо работать с с меню
«Ставить позициям оценки» и выбирать «Ход белых» или «Ход черных» нужную из шести
оценок( х , ! + – ? . )

Дальше в окошке «Старую оценку» «Не заменять» меняем на «Заменять
только на лучшую». Тогда будут меняться оценки по возрастающей и даже
точки из базы. И самое главное это меню «Брать полуходы с » » по «»

Тут Важно не ошибиться в подсчете полуходов. Например в примере 20. ab2 hg7
ход hg7 – это 40 полуход, а ход ab2 – это 39 полуход. То есть полухода смотрим
по ходу черных и умножая на цифру 2

Общее количество шашек на доске надо брать не менее «6″

Если числовые оценки в файле есть(а для этого надо при матче движков
в Эдэон-профи включать флажок «Статистика» после нажатия кнопок «Б» и «Ч») тогда
ставим галочку в пункте «При наличии числовой оценки ставить» и
выбираем нужные пункты, ставя галочку.

Числовые оценки поставлены для Эдэона-профи. Для других программ оценки будут другими и их надо корректировать.
При работе с числовыми оценками в верхнем меню «Ход белых» и «Ход
черных» должно стоять «Нет оценки»

12. Выполнение разрядов в Эдэон-100

Если Вы ходите выполнить разряд – выберите в меню (цифра 1) Игра на разряд и требуемый разряд, к примеру 3 юношеский(цифра 2) Для того, чтобы Вам был присвоен разряд, ВАм необходимо выиграть 2 партии из 4 партий

13. Анализ партий и книг в потоковом режиме

Чтобы анализировать партии или книги в потоковом режиме(то есть множество партий), надо загрузить файл в формате pdn с партиями или книгой через меню «Файл» (цифра 1), нажать «Анализ партий»(цифра 3) и Эдэон в автоматическом режиме проанализирует все 50 партий экс-чемпиона мира Анатолия Гантварага из книги «50 поединков на 100 клетках»(цифра 2)
Интересно наблюдать как движется желтый зайчик и дает оценку каждому ходу и глубину.

14. Миниатюры

В этом модуле, реализована мечта тренеров, игроков и композиторов – автоматическое создание -мини этюдов и мини-комбинаций с конкректным заданием. Также реализована возможность тренажера по данным миниатюрам. В качестве демо-версии поставляются все миниатюры 2 на 2 (можно включать и дамки) с любым количеством единственных ходов до результата(выигрыша или ничьи)
Чтобы открыть модуль «Миниатюры» надо нажать черный треугольник (цифра 1) и выбрать «Миниатюры»(цифра 1), далее ставим задание(цифра 2), выбираем количество шашек на доске белых(цифра 3),черных(цифра 4), общее количество ходов(цифра 5), количество единственных ходов(цифра 6), можно выбрать режим «Отдача шашек(комбинация)»(цифра 7), допускается шашка под ударом(свободный темп)(цифра 8), чтобы были всегда видны результаты в дебютной библиотеке – надо поставить галочку(цифра 9),чтобы модуль «Миниатюры» запоминал все отобранные миниатюры, надо поставить галочку(цифра 10) и для начала работы модуля «Миниатюры», надо нажать «Решать»(цифра 11)

Copyright (c) Алексей Одноклубов, Василий Наумик, Виктор Наумик 2008-2016

С уважением и мира в душе всем.

Пишите по адресу vasily. naumik@gmail. com или звоните +375(33)311-09-29